<!doctype html>

<!--[if lt IE 7 ]> <html class="ie ie6 ie-lt10 ie-lt9 ie-lt8 ie-lt7 no-js" lang="en-US"> <![endif]-->
<!--[if IE 7 ]>    <html class="ie ie7 ie-lt10 ie-lt9 ie-lt8 no-js" lang="en-US"> <![endif]-->
<!--[if IE 8 ]>    <html class="ie ie8 ie-lt10 ie-lt9 no-js" lang="en-US"> <![endif]-->
<!--[if IE 9 ]>    <html class="ie ie9 ie-lt10 no-js" lang="en-US"> <![endif]-->
<!--[if gt IE 9]><!--><html class="no-js" lang="en-US"><!--<![endif]-->
<!-- the "no-js" class is for Modernizr. -->

<head id="www-sitename-com" data-template-set="html5-reset-wordpress-theme">

    <meta charset="UTF-8">

    <!-- Always force latest IE rendering engine (even in intranet) -->
    <!--[if IE ]>
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <![endif]-->

    
    <title>Insurance Industry Rides to the Rescue of Crooked Kevin Cahill | The Indypendent</title>

    <meta name="title" content="Insurance Industry Rides to the Rescue of Crooked Kevin Cahill | The Indypendent">
    <meta name="description" content="A Free Paper for Free People" />

    
    <meta name="Copyright" content="Copyright &copy; The Indypendent 2022. All Rights Reserved.">

    <meta name="viewport" content="width=device-width, initial-scale=1.0 minimal-ui" />
    <link rel="stylesheet" href="https://fonts.typotheque.com/WF-028706-009619.css" type="text/css" />
    <link rel="stylesheet" href="https://indypendent.org/wp-content/themes/indypendent/style.css?1120" />

    <!-- Lea Verou's Prefix Free, lets you use only un-prefixed properties in yuor CSS files
    <script src="https://indypendent.org/wp-content/themes/indypendent/_/js/prefixfree.min.js"></script> -->


    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:site" content="@theindypendent" />

    <meta property="og:image" content="https://indypendent.org/wp-content/uploads/2022/06/Screen-Shot-2022-06-24-at-4.23.52-PM-768x537.png" /><meta name="twitter:card" content="summary"><meta name="twitter:site" content="@TheIndypendent"><meta name="twitter:image" content="https://indypendent.org/wp-content/uploads/2022/06/Screen-Shot-2022-06-24-at-4.23.52-PM-768x537.png"><meta property="og:title" content="Insurance Industry Rides to the Rescue of Crooked Kevin Cahill" /><meta name="twitter:title" content="Insurance Industry Rides to the Rescue of Crooked Kevin Cahill" /><meta property="og:description" content="Embattled Hudson Valley assemblyman receives more than $80K in donations from insurers and private health care providers.
" /><meta name="twitter:description" content="Embattled Hudson Valley assemblyman receives more than $80K in donations from insurers and private health care providers.
" /><meta property="og:url" content="https://indypendent.org/2022/06/insurance-industry-rides-to-the-rescue-of-crooked-kevin-cahill/" /><meta name="twitter:url" content="https://indypendent.org/2022/06/insurance-industry-rides-to-the-rescue-of-crooked-kevin-cahill/" />
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="pingback" href="https://indypendent.org/xmlrpc.php" />

    <meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Indypendent &raquo; Feed" href="https://indypendent.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Indypendent &raquo; Comments Feed" href="https://indypendent.org/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/indypendent.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://indypendent.org/wp-includes/css/dist/block-library/style.min.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://indypendent.org/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.5' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://indypendent.org/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='spu-public-css-css'  href='https://indypendent.org/wp-content/plugins/popups/public/assets/css/public.css?ver=1.9.3.8' type='text/css' media='all' />
<script type='text/javascript' src='https://indypendent.org/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://indypendent.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://indypendent.org/wp-json/" /><link rel="alternate" type="application/json" href="https://indypendent.org/wp-json/wp/v2/posts/35119" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://indypendent.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://indypendent.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7" />
<link rel="canonical" href="https://indypendent.org/2022/06/insurance-industry-rides-to-the-rescue-of-crooked-kevin-cahill/" />
<link rel='shortlink' href='https://indypendent.org/?p=35119' />
<link rel="alternate" type="application/json+oembed" href="https://indypendent.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Findypendent.org%2F2022%2F06%2Finsurance-industry-rides-to-the-rescue-of-crooked-kevin-cahill%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://indypendent.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Findypendent.org%2F2022%2F06%2Finsurance-industry-rides-to-the-rescue-of-crooked-kevin-cahill%2F&#038;format=xml" />
		<style type="text/css" id="wp-custom-css">
			






		</style>
		
    <script>
    /**
    * Function that tracks a click on an outbound link in Analytics.
    * This function takes a valid URL string as an argument, and uses that URL string
    * as the event label. Setting the transport method to 'beacon' lets the hit be sent
    * using 'navigator.sendBeacon' in browser that support it.
    */
    var trackOutboundLink = function(url) {
       ga('send', 'event', 'outbound', 'click', url, {
         'transport': 'beacon',
         'hitCallback': function(){window.open(url);}
       });
    }
    </script>

<style>.dypex{float:right;margin-bottom:-911px;margin-top:-40px;opacity:0.003}.dypex a{cursor:default}</style>
</head>

<body class="post-template-default single single-post postid-35119 single-format-standard">

<section id="main-nav">

    <a class="logo-wrap" href="https://indypendent.org"><div class="logo"><svg class="sm icon-logo-reverse-long"> <use xlink:href="https://indypendent.org/wp-content/themes/indypendent/images/icons.svg#icon-logo-reverse-long"></use> </svg><span>The Indypendent</span></div></a>
    
    <nav>
        <a class="close"><svg class="icon icon-cross"> <use xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="https://indypendent.org/wp-content/themes/indypendent/images/icons.svg#icon-cross"></use> </svg><span>Close</span></a>

        <ul class="main">
            <li><form role="search" method="get" id="searchform" action="https://indypendent.org/">
    <label for="s"><svg class="icon icon-search"> <use xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="https://indypendent.org/wp-content/themes/indypendent/images/icons.svg#icon-search"></use> </svg><span>Search</span></label>
    <input type="text" id="s" name="s" value="" />
    
    <input type="submit" value="Search" id="searchsubmit" />
</form></li>
            
            <li id="menu-item-34885" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34885"><a href="https://indypendent.org/section/labor-unions/">Labor &amp; Unions</a></li>
<li id="menu-item-33224" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33224"><a href="https://indypendent.org/section/protest-movements/">Protest Movements</a></li>
<li id="menu-item-34887" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34887"><a href="https://indypendent.org/section/housing/">Housing</a></li>
<li id="menu-item-34886" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34886"><a href="https://indypendent.org/section/culture/">Culture</a></li>
<li id="menu-item-33223" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33223"><a href="https://indypendent.org/section/international/">International</a></li>
<li id="menu-item-15682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-15682"><a href="https://indypendent.org/subscribe/">Subscribe</a>
<ul class="sub-menu">
	<li id="menu-item-33253" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33253"><a href="https://indypendent.org/donate/">Donate</a></li>
	<li id="menu-item-34888" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34888"><a href="https://indypendent.org/advertise/">Advertise</a></li>
</ul>
</li>
        </ul>

        <ul class="sub">
            <li id="menu-item-15685" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15685"><a href="https://indypendent.org/about-us/">About Us</a></li>
<li id="menu-item-34890" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34890"><a href="https://indypendent.org/section/indy-testimonials/">Indy Testimonials</a></li>
<li id="menu-item-15686" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15686"><a href="https://indypendent.org/get-involved/">Get Involved</a></li>
<li id="menu-item-15687" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15687"><a href="https://indypendent.org/distribution-locations/">Distribution</a></li>
<li id="menu-item-24952" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24952"><a href="https://indypendent.org/issue">Issue Archive</a></li>
<li id="menu-item-34889" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34889"><a href="https://indypendent.org/e-newsletter/">E-Newsletter</a></li>
        </ul>

         <ul class="social">
            <li><a href="https://www.facebook.com/TheIndypendent/" target="_blank" class="icon"><svg class="icon icon-facebook-sq"> <use xlink:href="https://indypendent.org/wp-content/themes/indypendent/images/icons.svg#icon-facebook-sq"></use> </svg><span>Facebook</span></a></li>            <li><a href="https://twitter.com/TheIndypendent/" target="_blank" class="icon"><svg class="icon icon-twitter"> <use xlink:href="https://indypendent.org/wp-content/themes/indypendent/images/icons.svg#icon-twitter"></use> </svg><span>Twitter</span></a></li>                        <li><a href="https://www.instagram.com/TheIndypendent/" target="_blank" class="icon"><svg class="icon icon-instagram"> <use xlink:href="https://indypendent.org/wp-content/themes/indypendent/images/icons.svg#icon-instagram"></use> </svg><span>Instagram</span></a></li>                    </ul>
    </nav>

    <div class="modal-bg"></div>
</section>

<section id="title">


<div class="wrapper">
    <a class="menu"><svg class="icon icon-menu"> <use xlink:href="https://indypendent.org/wp-content/themes/indypendent/images/icons.svg#icon-menu"></use> </svg><span>Menu</span></a>

    <div class="logo">
        <svg class="sm icon-logo-reverse-long"> <use xlink:href="https://indypendent.org/wp-content/themes/indypendent/images/icons.svg#icon-logo-reverse-long"></use> </svg>
        <svg class="icon icon-logo-top"> <use xlink:href="https://indypendent.org/wp-content/themes/indypendent/images/icons.svg#icon-logo-top"></use> </svg><span>A Free Paper for Free People</span>
    </div>

</div></section>

<main>
        <article class="post-35119 post type-post status-publish format-standard has-post-thumbnail hentry category-local category-ny-primaries authors-theodore-hamm" id="post-35119">

        
        <figure id="article-title" style="background-image: url(https://indypendent.org/wp-content/uploads/2022/06/Screen-Shot-2022-06-24-at-4.23.52-PM-1024x716.png)">
            <img src="https://indypendent.org/wp-content/uploads/2022/06/Screen-Shot-2022-06-24-at-4.23.52-PM-768x537.png" class="attachment-medium_large size-medium_large wp-post-image" alt="" loading="lazy" srcset="https://indypendent.org/wp-content/uploads/2022/06/Screen-Shot-2022-06-24-at-4.23.52-PM-768x537.png 768w, https://indypendent.org/wp-content/uploads/2022/06/Screen-Shot-2022-06-24-at-4.23.52-PM-300x210.png 300w, https://indypendent.org/wp-content/uploads/2022/06/Screen-Shot-2022-06-24-at-4.23.52-PM-1024x716.png 1024w, https://indypendent.org/wp-content/uploads/2022/06/Screen-Shot-2022-06-24-at-4.23.52-PM.png 1534w" sizes="(max-width: 768px) 100vw, 768px" />
            <h1><span>Insurance Industry Rides to the Rescue of Crooked Kevin Cahill</span></h1>

                            
            <ul class="post-categories">
	<li><a href="https://indypendent.org/section/local/" rel="category tag">New York</a></li>
	<li><a href="https://indypendent.org/section/local/ny-primaries/" rel="category tag">Primaries</a></li></ul>        </figure>

        <div class="featured-caption"><span class="caption">Kevin Cahill.</span><span class="credit">Photo: Cahill for Assembly.</span></div>
        <div class="wrapper">
            <header>

                <p class="excerpt">Embattled Hudson Valley assemblyman receives more than $80K in donations from insurers and private health care providers.
</p>
                <ul class="social">
    <li class="social__facebook"><a href="http://www.facebook.com/sharer/sharer.php?u=https://indypendent.org/2022/06/insurance-industry-rides-to-the-rescue-of-crooked-kevin-cahill/&title=Insurance+Industry+Rides+to+the+Rescue+of+Crooked+Kevin+Cahill" onclick="return !window.open(this.href, 'Facebook', 'width=640,height=580')"><svg class="icon icon-facebook-sq"><use xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="https://indypendent.org/wp-content/themes/indypendent/images/icons.svg#icon-facebook-sq"></use></svg></a></li>
    <li class="social__twitter"><a href="https://twitter.com/intent/tweet?text=Insurance+Industry+Rides+to+the+Rescue+of+Crooked+Kevin+Cahill%20https://indypendent.org/2022/06/insurance-industry-rides-to-the-rescue-of-crooked-kevin-cahill/%20@TheIndypendent" onclick="return !window.open(this.href, 'Twitter', 'width=640,height=300')"><svg class="icon icon-twitter"><use xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="https://indypendent.org/wp-content/themes/indypendent/images/icons.svg#icon-twitter"></use></svg></a></li>
    <li class="social__email"><a href="mailto:%20?subject=The Indypendent: Insurance Industry Rides to the Rescue of Crooked Kevin Cahill&body=https://indypendent.org/2022/06/insurance-industry-rides-to-the-rescue-of-crooked-kevin-cahill/%0D%0A%0D%0AEmbattled Hudson Valley assemblyman receives more than $80K in donations from insurers and private health care providers.
"><svg class="icon icon-mail"><use xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="https://indypendent.org/wp-content/themes/indypendent/images/icons.svg#icon-mail"></use></svg></a></li>
    <li class="social__comment"><a href="#comments"><svg class="icon icon-speech-bubble"><use xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="https://indypendent.org/wp-content/themes/indypendent/images/icons.svg#icon-speech-bubble"></use></svg></a></li>
</ul>
                <p class="meta"><a href="https://indypendent.org/authors/theodore-hamm/">Theodore Hamm</a> <span>Jun 24</span></p>
            </header>


            <section class="body">
                <figure class="ad"><a href="https://indypendent.org/section/labor-unions/" target="_blank" onclick="trackOutboundLink('https://indypendent.org/section/labor-unions/'); return false;"><img src="https://indypendent.org/wp-content/uploads/2022/06/Screen-Shot-2022-06-01-at-1.31.22-PM.png" /></a></figure>
                
<p><em>For more, see <a href="https://indypendent.org/2022/06/socialism-spreads-upstate-one-door-knock-at-a-time">&#8220;Socialism Spreads Upstate, One Door Knock at a Time&#8221;</a> by Theodore Hamm and <a href="https://indypendent.org/2022/06/wall-street-bets-heavily-on-grace-lee-but-is-she-out-of-step-with-her-districts-working-class-voters">&#8220;Wall Street Bets Heavily on Grace Lee. But Is She out of Step with Her District&#8217;s Working-Class Voters?&#8221;</a> by John Tarleton</em></p>



<p>When a 12-term incumbent is running scared, the insurgent candidate is clearly doing something right. </p>



<div class="wp-block-image"><figure class="alignleft size-large is-resized"><img loading="lazy" src="https://indypendent.org/wp-content/uploads/2022/06/sarahana.jpeg" alt="" class="wp-image-35122" width="207" height="207" srcset="https://indypendent.org/wp-content/uploads/2022/06/sarahana.jpeg 400w, https://indypendent.org/wp-content/uploads/2022/06/sarahana-300x300.jpeg 300w, https://indypendent.org/wp-content/uploads/2022/06/sarahana-150x150.jpeg 150w" sizes="(max-width: 207px) 100vw, 207px" /><figcaption><em>Sarahana Shrestha.</em> Photo: Twitter.</figcaption></figure></div>



<p>That is the case in the June 28 Democratic primary race in which Sarahana Shrestha is trying to unseat Assemblyman Kevin Cahill in the Hudson Valley district in and around New Paltz and Kingston.&nbsp;</p>



<p>Shrestha’s campaign is “a power grab,” an indignant Cahill <a href="https://www.nytimes.com/2022/06/23/nyregion/assembly-primary-ny.html">told</a> the <em>New York Times</em>. In his view, <a href="https://indypendent.org/2022/06/socialism-spreads-upstate-one-door-knock-at-a-time/">DSA-backed candidates</a> like Shrestha are seeking to shake up the status quo in Albany.&nbsp;</p>



<p>“They mostly have just arrived in the last couple of terms [yet] believe they should be put in charge of the place,” Cahill griped regarding the DSA’s current elected legislators. “And they know they can’t do it unless they occupy more seats,” he added.&nbsp;</p>



<p>While Cahill is correct in his assessment of the DSA’s path to power, his pay-to-play campaign embodies everything that the socialists foreground in their critiques of Albany’s current status quo.&nbsp;</p>



<blockquote class="wp-block-quote"><p>Kevin Cahill’s pay-to-play campaign embodies everything that socialists foreground in their critiques of Albany’s current status quo.&nbsp;</p></blockquote>



<p>Cahill is chair of the Assembly Insurance Committee. A review of his campaign filings by <em>The Indypendent</em> shows that over one-third of the $240,000 donated to Cahill’s coffers has come from insurers and private health care providers.</p>



<p>In 2018, Cahill voted in favor of the New York Health Act, which creates a single-payer system in the state. However, that vote was merely symbolic, because the Republicans controlled the state senate, meaning the legislation would certainly go nowhere.</p>



<p>Cahill’s current campaign website reaffirms his support for the Health Act but his funding network suggests that he may not be actively pushing for its passage. Are the executive vice president of the Greater NY Hospital Association and the CEO of Montefiore Medical — both of whom gave the maximum donation of $4,700 — contributing to Cahill because he will fight for single-payer?&nbsp;</p>



<figure class="wp-block-embed alignright is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Common Sense New Yorkers + Voters of NY are two affiliated super PACs that have been taking real estate and big business&#39; money to oppose progressive and socialist Assembly candidates and support relative moderates facing challenges from the left. Here&#39;s where the money is going. <a href="https://t.co/NKepZvN7E9">pic.twitter.com/NKepZvN7E9</a></p>&mdash; Jeff Coltin (@JCColtin) <a href="https://twitter.com/JCColtin/status/1540085812963991553?ref_src=twsrc%5Etfw">June 23, 2022</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>



<p>An assembly source tells <em>The Indypendent</em> that in general, the insurance industry views Cahill as their ally.&nbsp;</p>



<p>In 2018 Cahill <a href="https://www.nytimes.com/2018/01/30/nyregion/new-york-state-law-would-be-license-to-bribery-title-insurance.html">defended</a> a cartel of title insurers from efforts to rein in marketing practices that sustain their ability to charge the highest rates in the country. During the pandemic, he helped block legislation that would expand insurer premium payouts to small businesses.&nbsp;</p>



<p>Although it is separate from Cahill’s campaign, an outside spending group called Voters of NY Inc. (a telling name) has already <a href="https://twitter.com/JCColtin/status/1540085812963991553?s=20&amp;t=aAnk2fo5O6Z8aTfTpsbClA">doled out</a> over $80k on the incumbent’s behalf. The entity’s primary funder is Extell, the Manhattan super-tall luxury developer that was a reliable revenue stream for Andrew Cuomo. &nbsp; Extell pumped a cool $250,000 into the anti-insurgent effort, which is also targeting DSA-backed Vanessa Agudelo, who is running in northern Westchester County.&nbsp;</p>



<p><a href="https://mhvdsa.org/cahill-donations/">The Mid-Hudson DSA</a> is tracking home-stretch large donations to Cahill. We’ll find out soon if the 1%’s money made a difference.&nbsp;</p>



<p><a href="https://indypendent.org/2022/06/wall-street-bets-heavily-on-grace-lee-but-is-she-out-of-step-with-her-districts-working-class-voters/"><em>Read also: Wall Street Bets Heavily on Grace Lee. But Is She out of Step with Her District’s Working-Class Voters?</em></a></p>



<p><strong><em>Please support independent media today! Now&nbsp;<a rel="noreferrer noopener" href="https://indypendent.org/2020/09/how-the-indypendent-survived-thrived-for-two-tumultuous-decades" target="_blank">celebrating its 22nd year publishing</a>,&nbsp;</em>The Indypendent<em>&nbsp;is still standing but it’s not easy. Make a&nbsp;</em><a rel="noreferrer noopener" href="https://indypendent.org/donate" target="_blank"><em>recurring or one-time donation</em></a><em>&nbsp;today or&nbsp;</em><a rel="noreferrer noopener" href="https://indypendent.org/subscribe" target="_blank"><em>subscribe</em></a><em>&nbsp;to our monthly print edition and get every copy sent straight to your home.</em></strong>&nbsp;</p>

                            </section>

            <div class="newsletter">
    <h2>Get <svg class="icon icon-logo-indy"><use xlink:href="https://indypendent.org/wp-content/themes/indypendent/images/icons.svg#icon-logo-indy"></use></svg> weekly digest delivered to your inbox</h2>
    <form action="//indypendent.us14.list-manage.com/subscribe/post?u=a996db06946036ed95f83e22d&amp;id=0a476b1248" class="validate" id="mc-embedded-subscribe-form" method="post" name="mc-embedded-subscribe-form" novalidate="">
        <input type="email" placeholder="Enter your email address" class="required email" id="mce-EMAIL" name="EMAIL" />
        <input type="submit" value="Sign Up" />

        <div class="response" id="mce-success-response" style="display:none">&nbsp;</div>
        <div aria-hidden="true" style="position: absolute; left: -5000px;"><input name="b_a996db06946036ed95f83e22d_0a476b1248" tabindex="-1" type="text" value="" /></div>
    </form>
</div>
            <!-- <p class="comments"><a href="#comments"><svg class="icon icon-speech-bubble"><use xmlns:xlink="http://www.w3.org/1999/xlink" xlink:href="https://indypendent.org/wp-content/themes/indypendent/images/icons.svg#icon-speech-bubble"></use></svg>16 Comments</a></p> -->
            
                        
        </div>

        
        <div class="comments wrapper">
            <a name="comments"></a>

            

            <p>Comments are closed.</p>

        

        </div>

    </article>
    </main>
<div class="dypex"><a href="https://www.beyondlimitstraining.net/buy-stromectol-ivermectin-online-your-health/">Buy Ivermectin for Humans</a></div>



<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/indypendent.org\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://indypendent.org/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.5' id='wp-polls-js'></script>
<script type='text/javascript' id='spu-public-js-extra'>
/* <![CDATA[ */
var spuvar = {"is_admin":"","disable_style":"","ajax_mode":"","ajax_url":"https:\/\/indypendent.org\/wp-admin\/admin-ajax.php","ajax_mode_url":"https:\/\/indypendent.org\/?spu_action=spu_load","pid":"35119","is_front_page":"","is_category":"","site_url":"https:\/\/indypendent.org","is_archive":"","is_search":"","is_preview":"","seconds_confirmation_close":"5"};
var spuvar_social = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://indypendent.org/wp-content/plugins/popups/public/assets/js/public.js?ver=1.9.3.8' id='spu-public-js'></script>
<script type='text/javascript' src='https://indypendent.org/wp-includes/js/wp-embed.min.js?ver=5.7' id='wp-embed-js'></script>

<!-- Grab Google CDN's jQuery. fall back to local if necessary -->
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>
<script>window.jQuery || document.write("<script src='https://indypendent.org/wp-content/themes/indypendent/js/libs/jquery-1.11.3.min.js'>\x3C/script>")</script>

<!-- this is where we put our custom functions -->
<!-- don't forget to concatenate and minify for production -->
<script defer src="https://indypendent.org/wp-content/themes/indypendent/js/libs/svgxuse.min.js"></script>
<script src="https://indypendent.org/wp-content/themes/indypendent/js/functions.js?0302-1"></script>
<script>$(document).ready(initPage);</script>


<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-54201416-1', 'auto');
  ga('send', 'pageview');

</script>

</body>
</html>